Summenprodukt

Schauen wir zunächst einmal, was die Excel-Hilfe sagt:

Multipliziert die einander entsprechenden Komponenten der angegebenen Matrizen miteinander und gibt die Summe dieser Produkte zurück.

Syntax

 

Hinweise

·      Die als Argumente angegebenen Matrizen müssen bezüglich der Zeilen- und Spaltenanzahl identisch sein. Ist dies nicht der Fall, gibt SUMMENPRODUKT den Fehlerwert #WERT! zurück.

·      Matrixelemente, die keine numerischen Ausdrücke sind, behandelt SUMMENPRODUKT so, als wären sie mit 0 belegt.

Die erste Erkenntnis: Hier handelt es sich offenbar um eine Matrix-Funktion, auch wenn das formal nicht erkennbar wird. Anders, als bei Matrix-Formeln erscheinen in der Summenprodukt-Formel keine geschweiften Klammern. {}

Um mit dieser (anspruchsvollen!) Funktion wirklich glücklich zu werden, sollten Sie sich zwingend zunächst mit Matrix-Formeln vertraut machen!

Versuchen wir eine vorsichtige erste Annäherung mit einem kleinen Beispiel:

Abbildung 91, Summenprodukt

Nach herkömmlicher Methode würden Sie die Summe der Mehrwertsteuer für die einzelnen Artikel berechnen, indem Sie zunächst die Einzelwerte in den gelben Zellen C14:C21 bestimmen und diese Werte dann mit der Funktion Summe aufsummieren.

SUMMENPRODUKT macht im Prinzip nichts anderes. Nur laufen die Einzelberechnungen verdeckt ab, ohne dass Sie die Zwischenergebnisse zu Gesicht bekommen.
Die Formel  =SUMMENPRODUKT(B14:B21*B10) in Zelle C23 multipliziert die Elemente B14:B21 einzeln mit B10 (dem Mehrwertsteuersatz) und addiert sodann die Produkte.

Mit folgender Methode können Sie jedoch die einzelnen Berechnungsschritte sichtbar machen:

Markieren Sie die Zelle C23. Die Formel =Summenprodukt(B14:B21)*B10 erscheint in der Bearbeitungszeile.

Markieren Sie in der Bearbeitungszeile B14:B21*B10!

Abbildung 92, Matrixmultiplikation sichtbar machen

 

Mit der Funktionstaste F9 können Sie die markierte Teilformel berechnen.

Abbildung 93, Ergebnismatrix

Abbildung 93 zeigt das Ergebnis der Matrix-Multiplikation: eine weitere Matrix. Die Einzelelemente dieser Matrix sind die MWST-Beträge der einzelnen Artikel, die im nächsten Berechnungsschritt noch aufsummiert werden.

Eine weitere Möglichkeit, solche verdeckt ablaufenden Berechnungen zu analysieren, bietet das Werkzeug Formelauswertung (Formeln – Formelüberwachung – Formelauswertung).

s.a. Endlich kapiere ich Matrixformeln.xlsx

Die Formel =SUMMENPRODUKT(B14:B21+B14:B21*B10) in Zelle D23 addiert zu den einzelnen Produkten noch jeweils die Elemente B14:B21 und bildet dann die Gesamtsumme.

More:

Wahrheitswerte

Böse Falle